Frequently Asked Questions

I have an older source device that doesn't seem to be working with the Model 976. What could be going on here?
Last Updated a year ago

Make sure to use HDMI IN 5 or 6 when using older HDMI components. HDMI 2.0/HDCP 2.2, while supposedly backwards compatible, really only works well with devices that are at least HDMI 1.4 or above.

If you experience no audio, or video issues, with a device that is not HDMI 1.4 or above, you will need to use input 5 or 6.

Please Wait!

Please wait... it will take a second!